Elevated API Errors
Incident Report for Insituware
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 10:43 EST
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 18, 2020 - 10:25 EST
This incident affected: Insitucloud API Response Times/Failed Requests.