Elevated API Errors
Incident Report for Insituware
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 13:52 EDT
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 30, 2020 - 13:49 EDT
This incident affected: Insitucloud API Response Times/Failed Requests.